Catégories Firefox

Installer des extensions incompatibles avec Firefox 4 beta 2


Firefox, le navigateur Internet de Mozilla, est dès présent disponible en version 4 beta 2. Les onglets sont désormais sur le dessus, les performances revues à la hausse mais les extensions ne sont guère compatibles… à moins d’intervenir dans le fameux about:config.

N.B : ce tutoriel permet de passer outre le système de vérification de compatibilité de Firefox 4. Il n’est pas garanti que la plupart des extensions fonctionnent correctement. Pour autant, cette astuce fonctionnera avec nombre d’entre elles ce qui est toujours mieux que d’avoir le statut désactivé.

Commencez par exécuter Mozilla Firefox 4 en version beta. Vous pouvez le télécharger à l’adresse suivante :

Mozilla Firefox 4 dernière beta (7,7 MiB, 1 076 téléchargements)

Dans un nouvel onglet, saisissez about:config puis passez l’avertissement de sécurité en cliquant sur Je ferais attention, promis !

Faites un clic droit Nouvelle puis optez pour Valeur booléenne.

Capture d'écran - Firefox, création d'une valeur booléenne
Capture d'écran - Firefox, création d'une valeur booléenne

Indiquez extensions.checkCompatibility.4.0b pour valeur et choisissez False.

Capture d'écran - about:config, ajout d'une valeur booléenne
Capture d'écran - about:config, ajout d'une valeur booléenne

Redémarrez Firefox puis essayer d’installer une extension dite incompatible à partir du site officiel des add-ons. Aucun avertissement de compatibilité n’apparaît, vous autorisant l’installation sans contraintes.

Remarquez également le nouveau centre de Modules complémentaires. Des avertissements en texte rouge vous indiqueront que la plupart de vos extensions ne sont pas compatibles. Or, la plupart fonctionnent à la perfection !

Capture d'écran - Add-on incompatible mais fonctionnel sous Firefox 4 b2
Capture d'écran - Add-on incompatible mais fonctionnel sous Firefox 4 b2

Pratique pour bénéficier des services que délivrent ces extensions sans pour autant dépendre de la version du navigateur. Et vous, quels sont les extensions incompatibles dans votre situation ?

Mots-clés

5 commentaires

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

  • Luc 52

    Mille merci à l’auteur de cet article, cela fonctionne comme une nouvelle voiture.
    Pour ma part, mis à part ces petits problèmes de modules complémentaires, la version Bêta de Firefox 4.0 est en super bonne voie.
    Bon 15 août et encore merci.
    Luc 52

  • Lion77

    Merci pour cette combine

    Par contre j’ai un gros probleme : une fois sur FF 4b3 rien ne répond. Ni les Favoris, ni la recherche des add-ons. La barre d’adresse ne répond pas non plus.
    J’ai remarqué que la version 4b3, bien qu’enregistrée dans C:\Program Files(x86)\Mozilla\Firefox 4.0 beta3 utilise le meme profil (C:\Users\xxx\AppData etc..) que la version 3.6.8.

    Ne faudrait-il pas supprimer tous les addons ou du moins cerrtains comme TabMixPlus ?
    Merci

    • Le profil est justement réutilisé d’une version à une autre et c’est donc pour cela qu’il ne se trouve pas dans le dossier de l’application.

      Maintenant, si tu rencontres trop de problèmes, je te conseille de retourner dans une version stable.

      @tous : merci de vos commentaires sympathiques !